The easiest way to do this is now with a tool called Etcher, but if for whatever reason that isn’t working for you, here’s a way to do it natively in MacOS which should always work for you.
Table of Contents
Step 1: Download your ISO image
This is fairly self explanatory. Head over to the website for your Linux distribution of choice, eg ubuntu.com. Download the x64 (64 bit) version of the distro. You’ll end up with a .ISO file in your Downloads folder.
Step 2: Converting the ISO image to something your Macintosh recognises
Next, you need to convert the iso file into an image file that MacOS recognises so that you can stick it on a USB stick to boot from. Although you are back at the terminal for this, thankfully it’s not that onerous a task.
cd (directory where you downloaded the distro to)
hdiutil convert -format UDRW -o <<filename you want.iso.img>> <<filename of the download.iso>>
(so, in other words, hdiutil convert -format UDRW -o ubuntu1810.iso.img ubuntu-18.10-desktop-amd64.iso would convert the latter file into ubuntu1810.iso.img, which would be in the RAW, or more specifically UDRW format).
Mac OS likes to rename the file with a .dmg extension, to avoid confusion over that, it’s probably best that you rename it. A simple mv command will sort that one:
mv ubuntu1810.iso.img.dmg ubuntu1810.iso.img
(renames the file ubuntu1810.iso.img.dmg to ubuntu1810.iso.img).
Next, quickly type in diskutil list in the terminal. It should list one disk drive (if you have any external drives connected, disconnect them for now). Take a note of your Mac OS disk. It should be called /dev/disk0. Look for tell tale signs in there like ‘Macintosh HD’
Next, locate that USB stick of yours and whap it into the usb port. Please note that you want to have an empty USB stick, because this process will destroy any existing data on it.
Once you have the USB stick plugged in and all settled down, issue the following command:
diskutil list
You should see a list of disks like the one in the screenshot to the left. Note the red box around /dev/disk2. You can see that it has a Windows FAT32 partition, our usb stick is 8 GB big, you can see the size there is 8.1GB, which is clearly much smaller than the main hard drive, which is 500GB in size. Just make sure you identify which disk your usb stick is and take a note of that. The one we are using is /dev/disk2.
Now you need to unmount the usb disk, to do that issue the following command
diskutil unmountDisk /dev/disk2
Obviously if your USB stick is not disk2 then change it to suit. It should tell you that the unmount of all volumes on the disk were successful. Now all we have to do is copy the UDRW version of the iso image to your USB stick. For that, we will use trusty old dd 🙂
sudo dd if=ubuntu1810.iso.img of=/dev/rdisk2 bs=1m
Things you have to be aware of at this point
- This is a fully destructive command. It will blow up any disk you point it to, that’s why we made sure you got the note of that USB stick in diskutil list, above.
- if= is short for input file, meaning the input file is the name of the iso file you converted into the iso.img file. We are using the shortened filename here just for an example filename.
- of= is short for output file. The output file, is in fact a device. In this case, we are using (r)disk2; disk2 obviously is the drive we noted earlier, we use the r in front of it because that allows raw device access, so its marginally quicker.
- bs=1m means block size, 1 megabyte. You don’t have to use this option, however it will significantly increase the speed of the transfer to your USB stick.
Mac OS is going to bitch and moan that you have a volume it can’t read inserted. If it says Eject, click that, otherwise type diskutil eject /dev/disk2.
Step 3: booting the USB stick
Your USB stick is now bootable and ready to be used to install Linux onto your mac (or any other computer!). If you do want to run it from your mac, restart macOS and wait till you hear the ‘chime’ sound. Quickly hold down the alt/option key on your keyboard until you see a screen come up like this:

Simply select EFI boot from the options, hit return and your USB stick will boot up.